Как обновить прошивку Mikrotik из командной строки

Я уже писал как обновить прошивку на Mikrotik, оказалось что способ описанный в той статье не всегда срабатывает (не уверен, но похоже в некоторых версиях RouterOS сломана работа обновлений через Winbox, либо нужны какие-то дополнительные действия), после того как один из Mikrotik`ов отказался обновляться через Winbox и у меня, я решил написать еще одну статью с 100% рабочим способом обновления прошивки Mikrotik через консоль, он у меня срабатывал всегда и везде, проблемы могут быть и в этом случае но они не связаны с роутером, обновить прошивку не выйдет только если нет места для ее загрузки, либо она не загружается по каким-то другим причинам. Допускаю что может не работать обновление и через консоль, тогда остается еще один способ — обновление или восстановление прошивки Микротика через NetInstall (об этом тоже как-нибудь напишу). Но надеюсь у вас все получится.

Как обновить прошивку Mikrotik из консоли/терминала?

Попасть в терминал Микротика можно несколькими способами, я обычно захожу в консоль встроенную в Winbox, ниже будет скрин, в консоли нужно ввести несколько команд. Перед обновлением необходимо выбрать ветку из которой будем обновляться, для «боевых» устройств нужно выбирать stable или long term (первая включает в себя протестированные обновления и новые фичи, есть очень маленький шанс что при обновлении что-то из вашего конфига не будет работать, поэтому читайте список изменений, long term — включаются только исправления багов и ошибок, шансы что при обновлении что-то сломается минимальны), но если вы знаете что делаете или хотите испробовать какую-то новую возможность то можете выбрать testing или development.

Я выбираю stable, выполняем в консоли:

system package update set channel=stable

Узнаем есть ли новая версия:

system package update check-for-updates
channel: stable
installed-version: 6.43.8
latest-version: 6.43.11
status: New version is available

Да обновление доступно, скачиваем:

system package update download
channel: stable
installed-version: 6.43.8
latest-version: 6.43.11
status: Downloaded, please reboot router to upgrade it

Прошивка загружена в память роутера, осталось только перегрузить его для обновления:

system reboot

Вот так это выглядит в консоли:

Или тоже самое в Winbox:

Быстрая настройка Mikrotik с нуля для новичков, часть 1

Спонсор статьи
Это простая инструкция по быстрой базовой настройке Mikrotik для установки его вместо любого домашнего роутера, наглядная и не требующая специальных знаний — смотрим на картинку ставим галочки так же у себя и в конце получаем работающий роутер, статья рассчитана на домашних пользователей с минимальными знаниями или админов которым нужно быстро получить рабочее решение без длительного изучения документации.

Для настройки была выбрана «домашняя» версия из серии hap-lite, но инструкция подойдет и к любой другой модели. Настраивать будем модель RouterBOARD 941-2nD, по цене она сравнима с бытовыми роутерами, а по возможностям значительно их превосходит, в том числе и по стабильности в работе, в основном Mikrotik делает устройства из серии «настроил и забыл» (иногда и у них бывают проколы, как правило это касается каких-то специфических и редко используемых возможностей и легко исправляется установкой другой версии прошивки или сменой настроек).

Для настройки Mikrotik можно использовать:

  • Winbox (в Linux можно запустить в Wine или использовать mactelnet-client)
  • Браузер
  • SSH
  • Telnet
  • TikTool или Tik-App для Android

Так как мы сделаем полный сброс и доступ к устройству будет только по MAC, то для настройки нужно использовать Winbox.

Приступаем:

Скачиваем свежую версию Winbox (ссылка внизу страницы), и подключаем свой компьютер в любой порт Mikrotik. Удобно в первый порт подключать кабель от провайдера, во второй порт кабель второго провайдера и так далее, а оставшиеся свободными порты объединять в свитч/бридж и подключать в них локальные устройства. Запускаем Winbox, если нужно разрешаем доступ к сети:

В Winbox после запуска, нужно вписать данные для подключения, по умолчанию логин — admin, пароль пустой, IP-адрес 192.168.88.1, но можно подключиться проще, в нижней части окна перейдите на вкладку Neighbors в списке отобразятся все найденные устройства (в нашем случае там будет только одна запись) при клике по MAC или IP найденного устройства адрес будет помещен в строку Connect To, вам останется только вписать логин и нажать на кнопку Connect:

При первом заходе на устройство появится окно с предложение сохранить конфигурацию по умолчанию, либо удалить ее и настроить все самостоятельно. Если нажать ок, то далее настройка тривиальна и описана в этой статье я делал так много раз и проблем не было, но мы легких путей не ищем и настроим все самостоятельно, потому что я хоть и не сталкивался, но многие пишут что стандартная конфигурация не лишена недостатков и может глючить,  поэтому жмем Remove Configuration и ждем пока Микротик перезагрузится:

Если вдруг это окошко при заходе не появилось, значит на Микротик уже кто-то логинился, в этом случае нужно зайти System > Reset Configuration поставить галку «No Default Configuration» и нажать Reset Configuration:

После перезагрузки подключаемся снова с тем же логином и паролем, первым делом рекомендую сменить имя пользователя и установить свой пароль, это в разы повышает безопасность, заходим System > Users  кликаем дважды по admin, в открывшемся окне меняем имя пользователя жмем Password устанавливаем пароль:

Или можно выполнить в консоли:

/user add name=Новый_логин group=full password=пароль
/user remove admin

Первая команда добавит нового пользователя с указанным вами логином и паролем, вторая удалит пользователя admin, затем переподключаемся к Mikrotik под новым пользователем и далее все настройки выполняем под ним.

Переименование портов (не обязательно)

Переименовывать порты не обязательно, все будет работать и так, это делается исключительно для удобства настройки. Переименовываем первый порт, куда подключаем кабель от провайдера в WAN1 (если провайдеров несколько то WAN2 и так далее), остальным портам я оставляю старые имена, но их тоже можно переименовать в Lan1, Lan2 и т. д.

Или можно выполнить в консоли:

/interface ethernet set [find default-name=ether1] name=WAN1 — где ether1 — порт который нужно переименовать, а WAN1 — новое имя, так же переименовываем остальные порты если нужно.

Привязка MAC-адреса Mikrotik у провайдера

Если Вы меняете роутер на Микротик, то скорей всего знаете что у Вашего провайдера есть привязка по MAC-адресу, в этом случае нужно изменить MAC-адрес того порта Микротика куда подключается провайдера на MAC-адрес старого роутера, сделать это можно только из консоли, следующей командой:

/interface ethernet set WAN1 mac-address=00:00:00:00:00:00  — вместо нулей надо вписать MAC-адрес зарезервированный у провайдера, узнать его можно зайдя в веб-интерфейс старого роутера, в техподдержке своего провайдера или поискать наклейку на корпусе устройства.

Если, после выполнения команды MAC-адрес сменился на указанный Вами значит все ок:

Настройка подключения к провайдеру по DHCP

Всё больше провайдеров отдают настройки своим клиентам сразу по DHCP, это просто и удобно как для провайдера, так и для клиентов, минимум настройки со стороны клиента и возможность для провайдера выдавать не только IP адреса а и многие другие параметры. Заходим IP>DHCP Client > + Interface = WAN1, остальные настройки можно оставить стандартные. Use peer DNS — означает использование провайдерских DNS, NTP — синхронизация времени, Add Default Route — добавлять ли стандартный маршрут в таблицу маршрутизации и Default Route Distance — приоритет маршрута по сравнению с другими, если у Вас несколько провайдеров то изменяя приоритет можно управлять предпочитаемым маршрутом для трафика, 0 — самый высокий приоритет. 

Или тоже самое в консоли:

/ip dhcp-client add interface=WAN1 disabled=no

Настройка подключения к провайдеру со статическим IP

В этом случае настройки из предыдущего пункта просто прописываются вручную. У некоторых провайдеров свой статический IP можно получить по DHCP — просто каждый раз, ваш роутер будет получать одни и те же настройки. При подключении со статическим IP нужно заранее узнать у провайдера свои настройки, IP, Маску сети, Gateway (шлюз), DNS.

Например провайдер выдал такие настройки:

IP адрес: 192.168.0.11;
Mask/маска сети: может быть в двух видах например 255.255.255.0 или /24 что одно и тоже, Микротик понимает оба вида, бытовые роутеры как правило только первый
Gateway/шлюз: 192.168.0.1;
DNS сервера: 192.168.0.33 и 192.168.0.34

Добавляем IP-адрес на порт WAN1: IP > Addresses > + >Address: 192.168.0.11/255.255.255.0 > Interface > WAN1

Добавляем default route:  IP > Routes > + > Dst.Address:0.0.0.0/0; Gateway:192.168.0.1; Check gateway: ping; Distance: 1

При «прямом» подключении к провайдеру с динамическим или статическим адресом, при добавлении маршрута нужно всегда указывать IP шлюза, в выпадающем списке там можно выбрать в качестве шлюза какой-либо интерфейс, работает это только с виртуальными интерфейсами PPPoE, PPTP, VPN и т. д.

Добавляем DNS: IP > DNS > Servers: 192.168.0.33; 192.168.0.34

Галку Allow Remote Requests можно поставить если Вы хотите чтоб микротик выступал в роли кеширующего DNS, но в этом случае необходимо запретить обработку запросов DNS поступающих на порты которые смотрят в сеть провайдера и разрешить обрабатывать запросы только из локальной сети. Серверов DNS можно вписать несколько, для добавления еще одной строчки надо жать маленькую кнопку «Вниз» около поля.

Все тоже самое из консоли:

/ip address add address=192.168.0.11/255.255.255.0 interface=WAN1
/ip route add dst-address=0.0.0.0/0 gateway=192.168.0.1 check-gateway=ping distance=1
/ip dns set servers=192.168.0.33,192.168.0.34

Подключение к провайдеру по PPPoE

Если у Вас подключение к провайдеру по PPPoE, то по идее можно пропустить два предыдущих пункта, но часто провайдеры предоставляют доступ к каким-то локальным ресурсам в своей сети, и если они вам нужны то сперва следует выполнить настройку подключения к провайдеру по DHCP и затем вернуться к этому пункту. В бытовых роутерах это зачастую называется DualAccess или Russian PPPoE, до версии прошивки 6.0 на Микротик настройка такого доступа требовала некоторых танцев, но теперь все работает из коробки, поэтому не будем останавливаться на этом моменте. Перед настройкой соединения PPPoE, Вы должны знать логин и пароль, которые у большинства провайдеров выдаются при подключении и часто написаны на специальном листке с настройками.

Добавляем интерфейс: PPP > + > PPPoE Client затем на вкладке General задаем желаемое имя интерфейса Name = ISP1 и выбираем порт куда подключен кабель от провайдера Interface = WAN1. На вкладке Dial Out укажите логин и пароль и проверьте что остальные галочки стоят как на скринах ниже:

Или команда для консоли:

/interface pppoe-client add interface=WAN1 name=ISP1 disabled=no user=Логин password=Пароль use-peer-dns=yes add-default-route=yes default-route-distance=0

Далее в качестве интерфейса смотрящего в интернет будет выступать ISP1 его и будем использовать в настройках.

Подключение к провайдеру по L2TP/PPTP

Честно говоря я не припоминаю чтоб хотя бы раз настраивал такое подключение, но в некоторых странах этот тип подключений по прежнему остается широко распространенным, поэтому рассмотрим и его. Оба типа подключения требуют предварительной настройки IP-адреса и возможно прописывания маршрутов, подробности обычно можно узнать на сайте провайдера или в его поддержке. Предполагается что с этим вы разобрались и настроили статический или динамический IP-адрес по инструкции выше, а так же узнали логин, пароль и адрес VPN сервера для подключения.
Настройка аналогична PPPoE:
Добавляем интерфейс PPTP/L2TP: PPP > + > PPTP Client или L2TP Client смотря что у Вас, на вкладке General укажите имя подключения (например ISP1), а на вкладке Dial out нужно указать адрес сервера, логин, пароль, в Profile выбрать Default, поставить галку Add default route и выставить Distance = 1

Изменять/заполнять нужно только выделенные поля

Команды для консоли:

Для pptp-client:
/interface pptp-client add name=ISP1 disabled=no connect-to=Адрес сервера user=Логин password=Пароль add-default-route=yes default-route-distance=1 profile=default

Для l2tp заменить pptp-client на :
/interface l2tp-client add name=ISP1 disabled=no connect-to=Адрес сервера user=Логин password=Пароль add-default-route=yes default-route-distance=1 profile=default

 Подключение к интернет через 3G/4G модемы

В нашей модели USB-порта нет,  если в Вашей есть то в общем случае модем нужно искать в разделе Interfaces > LTE:

И работать с ним как с обычным портом, получить настройки по DHCP, поднять соединение PPPoE и т. д. подводных камней там достаточно можно и их описание может потянуть еще на целую статью. Список поддерживаемых модемов есть тут.

Настройка локальной сети

Первый порт у нас подключен к провайдеру и в нашем случае остается еще 3 локальных порта плюс модуль WiFi (в других моделях локальных портов может быть больше, как и модулей WiFi), сейчас они все как бы висят в воздухе и никуда не подключены, никакой трафик никуда не ходит, а нам нужно чтоб ходил, для этого объединим локальные порты и создадим сетевой мост, который объединит локальные порты и WiFi. Все порты и модуль WiFi Вы можете переименовать как Вам удобно, я этого делать не буду. Объединять порты в Микротик можно двумя способами, аппаратным (но только те которые относятся к одному чипу) и программным можно объединить любые. Аппаратное объединение очевидно быстрее, им объединим локальные порты а затем создадим программный сетевой мост между ними и WiFi-интерфейсом. Один из локальных портов, удобнее всего последний выбираем главным (master), остальные подчиняем ему, делается это просто к примеру у нас последний 4-й порт, он будет главным, его настройки не меняются, заходим в третий и выбираем для него мастер-портом четвертый:

Повторяем операцию с оставшимися свободными портами и должно получиться вот так:

4-й порт мастер, хоть это нигде и не указано, 2-й и 3-й имеют пометку S — Slave, подчиненный в нашем случае.

Команды для консоли:

/interface ethernet set [find default-name=ether2] master-port=ether4
/interface ethernet set [find default-name=ether3] master-port=ether4

Для остальных портов команды аналогичные, нужно только сменить имена портов на свои. Теперь нужно добавить к нашей локальной сети WiFi интерфейс, для этого создадим Bridge (мост).

Сперва создадим сам мост, а затем добавим в него нужные порты:
Bridge > + > Name:bridge1
Bridge > Ports > + > Interface: ether4; Bridge: bridge1
Bridge > Ports > + > Interface: wlan1; Bridge: bridge1

Или можно выполнить в консоли:
/interface bridge add name=bridge1
/interface bridge port add interface=ether4 bridge=bridge1 
/interface bridge port add interface=wlan1 bridge=bridge1

Заметьте что в bridge1 мы добавляем только мастер-порт, теперь bridge1 это интерфейс который смотрит в локальную сеть, его и будем использовать в дальнейшем для настройки. Для того чтоб работала локальная сеть на  bridge1 — нужно добавить IP-адрес, а чтоб IP-адреса раздавались автоматически нужно на нем же поднять DHCP-сервер.

Добавляем ip на bridge1: IP > Addresses > + > Address: 192.168.88.1/24; Interface: bridge1

Или в консоли:
/ip address add address=192.168.88.1/24 interface=bridge1

Далее нужно настроить раздачу IP-адресов для всех устройств подключенных к нашей локальной сети, как проводом так и по WiFi, сделать это можно двумя способами, с помощью мастера и вручную. Ниже показаны оба варианта, первый с помощью мастера, заходим в меню IP > DHCP Server > DHCP Setup и далее заполняем нужные поля и жмем Next. 

Все скрины я приводить не буду, статья и так длинная, мастер спросить на каком интерфейсе поднимать сервер в нашем случае это bridge1, затем адрес сети — 192.168.88.0/24, затем адрес шлюза — 192.168.88.1, затем размер пула в виде начального и конечного адреса — 192.168.88.100-192.168.88.254, затем нужно указать DNS сервера, я обычно использую гугловские 8.8.8.8 и 8.8.4.4, затем указываем время аренды, значение по умолчанию 00:10:00 — 10 минут, можно изменить на свое, можно оставить так, и на этом настройка закончена.
Все тоже самое можно настроить и вручную:
Создаем пул из которого будем выдавать адреса, в примере на 100 адресов, вы можете сделать его больше или меньше: IP > Pool > + > Name: pool1; Addresses:192.168.88.100-192.168.88.200

Или в консоли:
/ip pool add name=pool1 address=192.168.88.100-192.168.88.200

Теперь можно добавлять DHCP сервер на интерфейс bridge1 IP > DHCP Server > + , Name = dhcp1, Interface = bridge1, Address Pool = pool, остальные настройки не трогаем, Lease Time  у меня стоит полчаса, в домашней сети можно ставить 8 часов и больше:
Теперь переходим на вкладку Network, там нужно указать какие параметры будет отдавать наш сервер своим клиентам, необходимый минимум для работы сети Address, Gateway, Netmask — ее можно указать отдельно в поле или дописать к IP-адресу через / и DNS:

Или в консоли:
/ip dhcp-server add name=dhcp1 interface=bridge1 lease-time=00:30:00 address-pool=pool1
/ip dhcp-server network add address=192.168.88.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.88.1 netmask=24

Настройка WiFi

Я много раз настраивал Wi-Fi на Mikrotik, настройки по умолчанию — работают всегда, поэтому рекомендую их не трогать, если только Вы не уверены в том что делаете. Но иногда их можно оптимизировать под конкретную ситуацию, можно увеличить радиус покрытия, стабильность связи и в целом по сравнению с любым бытовым роутером, Микротик дает гораздо больше возможностей по настройке, что в условиях зашумленного городского эфира значительно повышает шансы добиться стабильной работы. Если все нормально работает с настройками по умолчанию — рекомендую их не трогать.

Активируем беспроводной интерфейс и приступаем к его настройке:

Настроим профиль безопасности, имя любое, некоторые старые устройства не умеют работать с шифрованием AES для них возможно придется включить устаревший вариант TKIP, который не рекомендуется из-за слабой безопасности, в поля Pre-Shared Key вводим пароль на нашу точку:

Настраиваем сам беспроводной интерфейс:

Вкладка Wireless:
Mode: ap bridge;
Band: 2gHz-B/G/N, если в сети нет старых устройств рекомендую выбирать Only-N, медленно но стабильно Only-G или 2gHz-B/G, в общем если не работает как надо экспериментируйте;
Channel Width: 20 MHz, если эфир свободен и Ваши устройства поддерживают можно поставить 40, скорость увеличится;фи
Frequency: auto, это тоже самое что и каналы в бытовых роутерах, рекомендую поставить авто, конкретный канал ставьте если знаете что делаете;
SSID: Название точки доступа;
Wireless Protocol: 802.11;
Securiity Profile: my_wifi, выбираем профиль созданный ранее;
Bridge Mode: enabled;
Default Authenticate: yes;
Default Forward: yes;
Hide SSID: no, позволяет скрывать Вашу точку из списка найденных устройств и в этом случае подключаться к ней придется вручную вводя имя, в общем жизнь эта настройка усложняет только владельцу, взломщики легко находят скрытые точки;

Далее вкладка Nstreme.
Отключаем все.

Консольный вариант:

/interface wireless set wlan1 disabled=no ssid=Mikrotik mode=ap-bridge band=2ghz-b/g/n frequency=auto bridge-mode=enabled wireless-protocol=any security-profile=my_wifi default-authentication=yes default-forwarding=yes hide-ssid=no
/interface wireless nstreme set wlan1 enable-nstreme=no enable-polling=no disable-csma=no

Теперь у нас есть рабочее подключение к Интернет и настроенная локальная сеть c WiFi, осталось «соединить» их между собой с помощью правил пакетного фильтра.

 Настройка пакетного фильтра (файервол)

Для настройки пакетного фильтра который по синтаксису схож с iptables, можно использовать Winbox или консоль, так как правил может быть много я опишу общий принцип, а вы выберете то что вам удобнее. Для настройки надо зайти в IP->Firewall, нас будут интересовать первые три вкладки Filter Rules, NAT и Mangle, каждая вкладка содержит список правил которые обрабатываются сверху вниз, кнопками плюс/минус правила можно добавлять и удалять, так же правила можно включать и отключать кнопками галочка/крестик. При нажатии на плюс, откроется новое окно для добавления правила, на вкладках General, Advanced и Extra задаются условия, на вкладке Action — выбирается действие для пакетов попавших под выбранные Вами условия, в большинстве случаев достаточно условий с вкладки General:
В большинстве случаев каждый пакет обрабатывается первым правилом под условия которого попал и дальше не проходит, но это поведение можно изменять.

Что делают правила из примера?
Доступ к Mikrotik будет полностью закрыт извне, но разрешен изнутри сети, на пинги Микротик будет отвечать и снаружи и изнутри, у пользователей внутри сети появится интернет. Это минимально необходимый набор правил. У вас должно получиться вот так:

Если будете добавлять правила через Winbox, жмете плюсик, и заполняете соответствующие поля значениями из скриншота выше, нужно добавить все 9 правил и именно в таком порядке. После переходите на вкладку NAT и по такому же принципу добавляете еще одно правило:

Но гораздо проще и быстрее отредактировать если нужно правила в текстовом редакторе и скопировать их в терминал, не забудьте нажать Enter, иначе последнее правило может не примениться:

Список команд с правилами пакетного фильтра для консоли:
/ip firewall filter
add chain=input protocol=icmp
add chain=input connection-state=new dst-port=80,8291,22 in-interface=bridge1 protocol=tcp src-address=192.168.88.0/24
add chain=input connection-state=new dst-port=53,123 protocol=udp src-address=192.168.88.0/24
add chain=input connection-state=established,related
add chain=output connection-state=!invalid
add chain=forward connection-state=established,new in-interface=bridge1 out-interface=WAN1 src-address=192.168.88.0/24
add chain=forward connection-state=established,related in-interface=WAN1 out-interface=bridge1
add action=drop chain=input
add action=drop chain=output
add action=drop chain=forward

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1 src-address=192.168.88.0/24

Если все сделано верно — то на устройствах подключенных к Mikrotik по WiFi или локальной сети должен появиться интернет. Это первая часть статьи, в ней мы настроили Mikrotik под себя и получили функционал обычного бытового роутера, но плюс RouterOS в том что она позволяет делать гораздо больше чем любой бытовой роутер, в ближайшем времени планирую написать вторую часть с рассказом о дополнительных возможностях и примерами по их настройке. Статью и команды в ней я проверял, но все же где-то могли закрасться ошибки, если у Вас что-то не получается сразу же пишите в комментариях, я перепроверю и помогу.

Спонсор статьи:

Самоучитель по MikroTik – теория и практика в видеоформате.

По видеокурсу «Настройка оборудования MikroTik» вы научитесь настраивать маршрутизатор с нуля для целей небольшого офиса. В основе курса лежит официальная программа MikroTik Certified Network Associate, но она значительно расширена, особенно в части закрепления знаний на практике. В курс входит 162 видеоурока и 45 лабораторных работ, объединенных в техническое задание. Если что-то непонятно, то можно задавать вопросы автору курса. Первые 25 уроков можно посмотреть бесплатно, форма заказа есть на странице курса по MikroTik.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Спонсор статьи
По умолчанию в стандартной конфигурации Mikrotik первый порт WAN в него подключается кабель интернет-провайдера, он настроен на автоматическое получение всех настроек по DHCP. Тут есть два варианта, зависят от используемого провайдером оборудования либо просто настройки выдаются по DHCP либо по DHCP + привязка по MAC-адресу. В первом случае Вам достаточно правильно подключить все кабели и Микротик начнет раздавать интернет, во втором придется позвонить провайдеру чтоб он сделал привязку по MAC. Настройка Микротика в обоих случаях сводится к установке пароля на Wifi (см картинки в конце статьи).

Подключаемся к Микротику с помощью Winbox (можно через браузер, а можно вообще все настраивать по SSH, мне больше всего нравится Winbox), при первом подключении нас спросят – оставить стандартную конфигурацию или удалить ее и настроить все с нуля, в этой статье я покажу как с минимальными правками получить то что Вам нужно из стандартной конфигурации, поэтому нажимаем Ок.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Если Ваш провайдер раздает интернет по Ethernet (витая пара) и использует для раздачи настроек DHCP – остается настроить только Wifi – переходите к концу статьи.

Если Ваш провайдер раздает интернет по Ethernet (витая пара) и у Вас статический IP, то нужна небольшая настройка.
Выбираем в меню слева IP-DHCP Client и в открывшемся окошке выбираем наш интерфейс и жмем крестик, мы выключаем получение настроек по DHCP, затем в меню IP выбираем Addresses, там жмем синий плюс  и в окошке прописываем выданные провайдером настройки, наш статический IP, маску (Network) и выбираем в Interface порт куда подключен кабель провайдера, по умолчанию это ether1-gateway, жмем ок. Далее остается установить пароль на Wifi и можно пользоваться интернетом.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Некоторые провайдеры для авторизации пользователей и учета трафика используют подключения по протоколам PPPoE, PPTP, SSTP, L2TP в таком случае необходимо настроить соединение. Слева в меню выбираем PPP, в открывшемся окошке жмем синий плюс и выбираем нужный нам протокол (обычно указан в листе с настройками который выдает провайдер вместе с договором, либо можно узнать в техподдержке), мы настроим подключение PPPoE, подключения по другим протоколам выполняются аналогично. Выбираем в меню PPPoE Client:

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Откроется окно в котором надо заполнить поля: Name – название интерфейса, я обычно использую название провайдера, чтоб различать интерфейсы если каналов больше одного, в меню Interfaces надо выбрать первый порт, в который подключен кабель провайдера

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Переходим на вкладку Dial Out, здесь заполняем Service – произвольное имя, User, Password – заполняем значениями которые выдал провайдер. Устанавливаем галочки – Use Peer DNS и Add Default Route. В этом же окне можно нажать кнопку Apply, и если все верно будет установлено соединение и внизу окна появится Status: connected.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Можно перейти на вкладку Status и просмотреть подробности подключения, время, продолжительность соединения, ip-адрес.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Теперь для того чтоб появился интернет на устройствах подключенных к портам 2-4 и по Wifi остается настроить NAT. В меню слева выбираем IP-Firewall и переходим на вкладку NAT, там кликаем дважды по правилу в списке и в Out Interface выбираем название интерфейса которое мы указали ранее при создании соединения в моем случае это maklaud, жмем Ок.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

После этого на всех устройствах подключенных к Микротику должен появиться интернет.

Теперь остается настроить Wifi, по умолчанию он без пароля, если Вас это устраивает – на этом настройка закончена, если нет то устанавливаем пароль.

В меню слева выбираем Wireless, переходим на вкладку Security Profiles и жмем синий плюс, имя профиля можете написать любое, на картинке представлен вариант наиболее безопасной настройки Wifi, но многие устройства не поддерживают WPA2 или шифрование AES, поэтому если какое-то устройство не может подключиться – необходимо поставить остальные галочки в верхнем квадрате. В нижнем впишите пароль к Wifi.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Затем перейдите на вкладку Interfaces, и кликните дважды по wlan1, как видно из скрина при указанных настройках, из подключения по Wifi можно выжать практически 100 мегабит, в весьма неблагоприятных условиях, вокруг рядом около 10 точек. У меня все устройства поддерживают стандарт N поэтому я в BAND – выбрал использовать только его, если у Вас есть старые устройства B или G стандарта тогда выбирайте 2Hz-B/G/N. Скорость при этом может снизиться.

Настройка подключения к интернет и Wifi на Mikrotik и Mikrotik hap lite

Спонсор статьи:

Самоучитель по MikroTik – теория и практика в видеоформате.

По видеокурсу «Настройка оборудования MikroTik» вы научитесь настраивать маршрутизатор с нуля для целей небольшого офиса. В основе курса лежит официальная программа MikroTik Certified Network Associate, но она значительно расширена, особенно в части закрепления знаний на практике. В курс входит 162 видеоурока и 45 лабораторных работ, объединенных в техническое задание. Если что-то непонятно, то можно задавать вопросы автору курса. Первые 25 уроков можно посмотреть бесплатно, форма заказа есть на странице курса по MikroTik.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

Спонсор статьи

Рекомендую использовать более простой способ обновления прошивки Микротик через консоль
На работе я давно использую роутеры Mikrotik они себя зарекомендовали просто отлично – стабильная работа и большое количество настроек и функций, аналогов за такие деньги на данный момент нет, поэтому я хотел купить Mikrotik и себе домой, но цена кусалась. Вопрос цены отпал с выходом MikroTik RB941-2nD (hAP lite), который стоит примерно так же как и конкуренты, но обладает всеми преимуществами более старших моделей Mikrotik. Процессора и размера ОЗУ для решения задач бытового роутера – хватит с запасом. В этой статье я расскажу как подключить Mikrotik и как обновить прошивку. Подключение ничем не отличается от других роутеров, Hap lite поставляется со стандартной конфигурацией,  в первый порт (помечен красным) подключается кабель интернет-провайдера, в остальные 3 порта объединены в свитч и туда можно подключать свои устройства. Для перепрошивки можно использовать любой из портов 2-3 или подключение по Wifi. На своем компьютере на сетевом адаптере нужно включить автоматическое получение адреса (обычно в 99% случаев так и есть). Если хотите использовать статический ip – то используйте любой из диапазона 192.168.88.2-192.168.88.254, у mikrotik ip по умолчанию 192.168.88.1.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

Мне достался mikrotik с прошивкой v6.28.1, я перепрошил его до v6.30.1 – но она оказалась глючная в ней не были доступны некоторые настройки и соединение с winbox постоянно рвалось, после этого пару месяцев микротик провалялся на полке, а недавно я достал его и обновил прошивку до v6.34.1 – в ней все работает как надо.

Итак, для того чтобы обновить прошивку – сперва надо ее скачать, для этого идем на сайт Микротика и скачиваем нужную версию, если у вас обычный Микротик (не lite) нужно скачивать прошивку из первой строки, помечена как MIPSBE, у нас версия HAP Lite, поэтому нам нужна прошивка SMIPS. На сайте доступны три версии – предыдущая с исправленными ошибками (Bugfix only), текущая (Current) и следующая версия — RC (Release candidate), которая после полного тестирования станет текущей. Вы можете попробовать любую, я рекомендую скачивать Current и если с ней что-то не так то либо предыдущую версию либо RC, есть вероятность что они будут работать в ваших условиях стабильней. Прошивки Mikrotik обновляются регулярно, так что если что-то не работает как надо – следите за обновлениями (для этого внизу страницы  есть форма для подписки на уведомления о выходе новых версий).

Заходим на сайт и скачиваем mine package:

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

Как подключиться к Mikrotik я писал в начале статьи, далее предполагается что вы верно подключили все кабели и правильно настроили сетевой адаптер на Вашем компьютере или ноутбуке. Далее два варианта процесса прошивки, через браузер и через утилиту Winbox.

Обновляем прошивку Mikrotik через браузер, введите в адресную строку https://192.168.88.1 если все настроено и подключено верно то вы увидите веб-интерфейс, кликайте в меню “Files” и загружайте в Микротик скачанную ранее прошивку.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

После того как файл с прошивкой загрузился, выбираем в меню System – Reboot, в появившемся окне жмем ок.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

Микротик автоматически установит новую версию прошивки после перезагрузки.

Так же можно обновить прошивку с помощью Winbox, его можно скачать либо с сайта Mikrotik либо зайдя на свой роутер через браузер:

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

Я рекомендую второй способ, это повышает шансы на более стабильную работу Winbox, те версии что я скачивал с сайта Микротика либо вообще не видели мой девайс либо постоянно рвалось соединение.

Скачиваем Winbox и запускаем, в нем переходим на вкладку Neighbors, немного ждем и в списке ниже появятся найденные устройства к которым можно подключиться. Winbox позволяет подключаться либо по mac адресу либо по ip, я рекомендую второй вариант у меня при подключении по ip соединение рвется намного реже. Подключение по mac адресу нужно когда Вас не устраивает стандартная конфигурация и вы хотите самостоятельно настроить роутер с нуля.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

Кликаем по ip в списке, пишем в строке Login – admin и жмем Connect. Пароль по умолчанию пустой.

После успешного соединения откроется окно Winbox, интерфейс здесь практический такой же как и в веб-конфигураторе, открываем меню Files, и перетягиваем мышкой ранее скачанную прошивку в окно со списком файлов:

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

В списке появится файл с прошивкой и в окошке будет отображаться процесс загрузки. Важно! После загрузки прошивки проверьте ее размер в окне, если он меньше чем нужно – процесс следует повторить. (В некоторых случаях мне приходилось загружать прошивку 4-5 раз). Если прошивка загрузится не полностью – ничего страшного не случится просто она не установится и микротик загрузится со старой версией.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

После того как прошивка загрузилась, просто перегружаем Микротик, выбираем Reboot и затем жмем Ок.

Обновление прошивки на Mikrotik hap lite (инструкция подходит для всех роутеров Mikrotik)

После перезагрузки будет установлена новая версия прошивки.

Спонсор статьи:

Самоучитель по MikroTik – теория и практика в видеоформате.

По видеокурсу «Настройка оборудования MikroTik» вы научитесь настраивать маршрутизатор с нуля для целей небольшого офиса. В основе курса лежит официальная программа MikroTik Certified Network Associate, но она значительно расширена, особенно в части закрепления знаний на практике. В курс входит 162 видеоурока и 45 лабораторных работ, объединенных в техническое задание. Если что-то непонятно, то можно задавать вопросы автору курса. Первые 25 уроков можно посмотреть бесплатно, форма заказа есть на странице курса по MikroTik.