Решено: Как сбросить принтер HP-P1102W к заводским настройкам

Как сбросить принтер HP-P1102W к заводским настройкам

  1. Выключите принтер кнопкой на корпусе
  2. Нажмите и удерживайте обе кнопки — включения Wifi и «Отмена»
  3. Не отпуская кнопок включите принтер, дождитесь пока он перестанет шуметь и затем отпустите обе кнопки
  4. Нажмите кнопку «Отмена» и удерживая ее примерно 5-10 секунд распечатайте лист с конфигурацией и убедитесь что настройки сброшены

 

Как быстро удалить старые письма в Gmail, простой способ

Редко, но возникает задача удалить старые письма в Gmail чтоб освободить место, ведь если весь объем будет использован, то вы перестанете получать новые письма до тех пор пока не освободите достаточно места, а ваши собеседники при попытке отправить вам письмо будут получать ответное с ошибкой, где скорей всего будет написано что в вашем ящике больше нет свободного места.

Если что-то изменится я обновлю пост, но на начало 2019 года Gmail предоставляет пользователям 15 Гб в обычном аккаунте и 30 в Гб в бизнес аккаунте, этот объем предоставляется для всех сервисов (кроме Google Photo) — для Gmail, для Гугл-диска и т. д., поэтому если вы используете Гугл-Диск, можно удалить на нем ненужные файлы и этого возможно будет достаточно. Если же вы используете только Gmail, то значит весь объем занят письмами и тогда эта статья для вас.

Когда свободного места для писем остается немного, Gmail вас предупредит плашкой в самом верху страницы:

Как быстро удалить старые письма в Gmail

Удаляем старые письма в Gmail

Конечно можно удалять старые письма в Gmail по одному, но учитывая сегодняшние объемы переписки, у вас легко может накопиться несколько тысяч или даже десятков тысяч писем и удаление по одному тут не вариант. К счастью в Gmail можно использовать поисковые операторы, с их помощью можно отобрать ненужные письма для удаления, это могут быть письма за какой-то период, до или после какой-то даты, за период, от конкретного отправителя, больше какого-то размера и т. д. В моем случае всё просто, я удаляю письма старше чем несколько месяцев, в примере удаляются все письма в папке с датой старше 4 месяцев, для этого используется поисковый оператор — older_than:4m, вместо m (месяц) можно использовать — d и y (день и год соответственно), обратите внимание письма будут удалены только в той папке в которой вы выполнили поиск.

Заходим во входящие и пишем вверху в строке поиска:

Как быстро удалить старые письма в Gmail

Загружаются все сообщения подходящие под наше условие, ставим галочку «выбрать все» и появится подсказка — «выбрать все что соответствует запросу», жмем на нее

Как быстро удалить старые письма в Gmail

Затем нажимаем удалить и подтверждаем свое решение (сразу письма попадут в корзину, так что вы еще сможете передумать)

Как быстро удалить старые письма в Gmail

Обработка запроса может занять какое-то время, просто немного подождите, на этом этапе письма которые мы выбрали находятся в корзине, тут я рекомендую проверить папку входящие и убедиться что не удалилось ничего лишнего и после этого переходить к очистке корзины, после которой восстановить письма уже не получится (если только вы не делали резервную копию) Если вы уверены что эти письма не нужны — очищаем корзину, наверное все знают, но на всякий случай в Gmail корзина прячется в меню слева, в выпадающем списке «Еще»:

Рядом с корзиной находится и папка Спам, переходим в корзину:

Как быстро удалить старые письма в Gmail

В корзине можно просмотреть письма и затем если все нормально и нужных писем в корзине нет, в самом верху жмем «Очистить корзину»:

после завершения очистки, можно перейти во входящие и проверить под списком писем объем свободного пространства (иногда нужно обновить страницу или подождать):

После очистки входящих (обычно эта самая большая по объему папка), такую же операцию можно повторить в папке «Отправленные» и других.

Если этот вариант не подходит или его недостаточно используйте поисковые операторы для отбора ненужных писем.

Основные поисковые операторы:

Найти письма большего (больше 10 Мб) или меньшего размеров (меньше 5 Мб): larger:10m    smaller:5m

Найти все письма по отправителю:  from:Василий

Найти все письма которые вы отправили кому-то: to:Петр

Найти все письма с ярлыком: label:работа

Найти письма которым присвоен  has:userlabels  или не присвоен ярлык has:nouserlabels

Найти все письма с вложениями: has:attachment

Найти все помеченные письма: is:starred

Найти все отложенные письма: is:snoozed

Найти все непрочитанные письма: is:unread

Найти все прочитанные письма: is:read

Так же операторы можно комбинировать друг с другом используя логическое или — OR, например такой запрос: from:youtube OR from:google покажет все письма полученные от Youtube и Google.

Как быстро и просто выполнять HTTP-запросы к web-серверу из VBA

О чем эта статья?

Я немного занимаюсь программированием, откровенно говоря по большей части это говно-код, но я и не настоящий сварщик. И так вышло что в ру-нете неплохо освещены азы, чуть хуже вопросы посложнее, а некоторые вопросы либо не освещены вовсе, либо подавляющее большинство пишет что это невозможно в принципе или невозможно без изобретения велосипедов. А может я просто плохо гуглил. В общем понадобилось мне однажды выполнять GET и POST запросы из VBA, это не сложный в общем-то язык для офисного пакета Microsoft, в этой статье вы узнаете как без установки сторонних компонент, изобретения велосипедов и прочего общаться с серверами в Интернет из Excel, Access или других офисных приложений.

Как работать с Веб-серверами из VBA?

Первым делом нужно открыть редактор VBA и подключить библиотеку Microsoft XML -> Tools -> References — в списке находим нужную библиотеку и ставим галочку: В зависимости от версии офиса, установленных обновлений и другого софта у вас в списке могут быть разные версии, выбирать можно любую: 1. Microsoft XML, v 3.0. 2. Microsoft XML, v 4.0 (если установлен пакет MSXML 4.0). 3. Microsoft XML, v 5.0 (устанавливается вместе с  Office 2003 – 2007). 4. Microsoft XML, v 6.0 устанавливается с последними версиями MS Office 2010 и новее. У меня в системе были все из списка, я пробовал разные и со всеми работало, решил подключить самую новую.

А далее все просто, вот пример GET-запроса:

Private Sub get_zaproz_from_VBA_Click() ' это кнопка на форме
Dim xmlhttp As New MSXML2.XMLHTTP60, myurl As String
myurl = "https://kakpedia.org"
xmlhttp.Open "GET", myurl, False
xmlhttp.Send
MsgBox (xmlhttp.responseText)
End Sub
И если все сделано верно, то откроется окошко с Html-кодом, который отдал сервер. Некоторые серверы ничего не отдадут (например гугл мне почему-то отказался отвечать) — это нормально, пробуйте несколько.

Задать если необходимо, HTTP-заголовки можно вот так:

xmlhttp.setRequestHeader "Content-Type", "text/json"
xmlhttp.setRequestHeader "Content-Type", "application/x-www-form-urlencoded"
xmlhttp.setRequestHeader "User-Agent", "Mozilla/5.0 (iPad; U; CPU OS 3_2_1 like Mac OS X; en-us) AppleWebKit/531.21.10 (KHTML, like Gecko) Mobile/7B405"
xmlhttp.setRequestHeader "Authorization", AuthCredentials

POST-запрос из VBA:

Public Sub post_zapros_from_VBA()
Dim xmlhttp As New MSXML2.XMLHTTP, myurl As String
myurl = "Сюда впишите адрес формы"
xmlhttp.Open "POST", myurl, False
xmlhttp.setRequestHeader "Content-Type", "application/x-www-form-urlencoded"
xmlhttp.Send "name=codingislove&email=admin@codingislove.com"
MsgBox (xmlhttp.responseText)
End Sub

Простая авторизация:

user = "логин"
password = "пароль"
xmlhttp.setRequestHeader "Authorization", "Basic " + Base64Encode(user + ":" + password)


Несколько способов сохранить большой отчет из 1С в Excel

Решил сохранить шпаргалку на память, 1С я практически не касаюсь, но изредка приходится что-то делать. В 1С 7.7 отчеты можно сохранять в формате Excel для последующей более удобной с ними работы, и пока отчеты небольшие — проблем нет, они сохраняются быстро и без ошибок. Но стоит попробовать сохранить отчет с несколькими тысячами строк (молчу о десятках тысяч), как 1С сходит сума, либо сохранение занимает совсем уж неразумное время (часы и сутки) либо 1C просто зависает. Но способы сохранить огромный отчет из 1С и сделать это за разумное время есть.

Сохраняем большие отчеты из 1С за разумное время, способ первый:

Способ проверенный, срабатывает в большинстве случаев, выделите все строки отчета, (не забудьте отжать  кнопку «Только просмотр», иначе настройки будут неактивны) и принудительно установите им одинаковую высоту, например 5. Жмите ОК и пробуйте сохранить отчет в формате Excel — должно все получиться. Если нет — пробуйте следующие способы.

Сохраняем большие отчеты из 1С за разумное время

Сохраняем большие отчеты из 1С за разумное время, способ второй:

Уберите объединение ячеек, если мне не изменяет память, для этого придется открывать конфигуратор и править печатную форму конкретного отчета, в общем скорей всего понадобится программист, но если вы можете это сделать — делайте, и сохранение в формате Excel, заметно ускорится. Если править печатную форму не вариант — есть еще.

Сохраняем большие отчеты из 1С за разумное время, способ третий:

Этот способ подходит как для ускорения сохранения больших отчетов, так и для обхода ограничения в 65535 строк для старых версий Excel. При сохранении отчета выберите формат htm или html, затем получившийся файл — откройте в Excel. Он понимает Html-разметку и преобразует ее в таблицу. Затем из Excel этот файл можно пересохранить еще раз уже в нужном вам формате Excel.

Сохраняем большие отчеты из 1С за разумное время, способ четвертый:

Если ни один (и даже все вместе) из предыдущих способов не помог, используйте Йоксель (Yoksel) – набор программных средств для работы с табличными документами, который интегрируется в 1С и значительно расширяет ее возможности по экспорту табличных данных в удобном для вас формате. Минус этого способа — придется звать программиста, чтоб всё подключил и настроил.

Быстрая настройка Mikrotik с нуля для новичков, часть 1

Спонсор статьи
Это простая инструкция по быстрой базовой настройке Mikrotik для установки его вместо любого домашнего роутера, наглядная и не требующая специальных знаний — смотрим на картинку ставим галочки так же у себя и в конце получаем работающий роутер, статья рассчитана на домашних пользователей с минимальными знаниями или админов которым нужно быстро получить рабочее решение без длительного изучения документации.

Для настройки была выбрана «домашняя» версия из серии hap-lite, но инструкция подойдет и к любой другой модели. Настраивать будем модель RouterBOARD 941-2nD, по цене она сравнима с бытовыми роутерами, а по возможностям значительно их превосходит, в том числе и по стабильности в работе, в основном Mikrotik делает устройства из серии «настроил и забыл» (иногда и у них бывают проколы, как правило это касается каких-то специфических и редко используемых возможностей и легко исправляется установкой другой версии прошивки или сменой настроек).

Для настройки Mikrotik можно использовать:

  • Winbox (в Linux можно запустить в Wine или использовать mactelnet-client)
  • Браузер
  • SSH
  • Telnet
  • TikTool или Tik-App для Android

Так как мы сделаем полный сброс и доступ к устройству будет только по MAC, то для настройки нужно использовать Winbox.

Приступаем:

Скачиваем свежую версию Winbox (ссылка внизу страницы), и подключаем свой компьютер в любой порт Mikrotik. Удобно в первый порт подключать кабель от провайдера, во второй порт кабель второго провайдера и так далее, а оставшиеся свободными порты объединять в свитч/бридж и подключать в них локальные устройства. Запускаем Winbox, если нужно разрешаем доступ к сети:

В Winbox после запуска, нужно вписать данные для подключения, по умолчанию логин — admin, пароль пустой, IP-адрес 192.168.88.1, но можно подключиться проще, в нижней части окна перейдите на вкладку Neighbors в списке отобразятся все найденные устройства (в нашем случае там будет только одна запись) при клике по MAC или IP найденного устройства адрес будет помещен в строку Connect To, вам останется только вписать логин и нажать на кнопку Connect:

При первом заходе на устройство появится окно с предложение сохранить конфигурацию по умолчанию, либо удалить ее и настроить все самостоятельно. Если нажать ок, то далее настройка тривиальна и описана в этой статье я делал так много раз и проблем не было, но мы легких путей не ищем и настроим все самостоятельно, потому что я хоть и не сталкивался, но многие пишут что стандартная конфигурация не лишена недостатков и может глючить,  поэтому жмем Remove Configuration и ждем пока Микротик перезагрузится:

Если вдруг это окошко при заходе не появилось, значит на Микротик уже кто-то логинился, в этом случае нужно зайти System > Reset Configuration поставить галку «No Default Configuration» и нажать Reset Configuration:

После перезагрузки подключаемся снова с тем же логином и паролем, первым делом рекомендую сменить имя пользователя и установить свой пароль, это в разы повышает безопасность, заходим System > Users  кликаем дважды по admin, в открывшемся окне меняем имя пользователя жмем Password устанавливаем пароль:

Или можно выполнить в консоли:

/user add name=Новый_логин group=full password=пароль
/user remove admin

Первая команда добавит нового пользователя с указанным вами логином и паролем, вторая удалит пользователя admin, затем переподключаемся к Mikrotik под новым пользователем и далее все настройки выполняем под ним.

Переименование портов (не обязательно)

Переименовывать порты не обязательно, все будет работать и так, это делается исключительно для удобства настройки. Переименовываем первый порт, куда подключаем кабель от провайдера в WAN1 (если провайдеров несколько то WAN2 и так далее), остальным портам я оставляю старые имена, но их тоже можно переименовать в Lan1, Lan2 и т. д.

Или можно выполнить в консоли:

/interface ethernet set [find default-name=ether1] name=WAN1 — где ether1 — порт который нужно переименовать, а WAN1 — новое имя, так же переименовываем остальные порты если нужно.

Привязка MAC-адреса Mikrotik у провайдера

Если Вы меняете роутер на Микротик, то скорей всего знаете что у Вашего провайдера есть привязка по MAC-адресу, в этом случае нужно изменить MAC-адрес того порта Микротика куда подключается провайдера на MAC-адрес старого роутера, сделать это можно только из консоли, следующей командой:

/interface ethernet set WAN1 mac-address=00:00:00:00:00:00  — вместо нулей надо вписать MAC-адрес зарезервированный у провайдера, узнать его можно зайдя в веб-интерфейс старого роутера, в техподдержке своего провайдера или поискать наклейку на корпусе устройства.

Если, после выполнения команды MAC-адрес сменился на указанный Вами значит все ок:

Настройка подключения к провайдеру по DHCP

Всё больше провайдеров отдают настройки своим клиентам сразу по DHCP, это просто и удобно как для провайдера, так и для клиентов, минимум настройки со стороны клиента и возможность для провайдера выдавать не только IP адреса а и многие другие параметры. Заходим IP>DHCP Client > + Interface = WAN1, остальные настройки можно оставить стандартные. Use peer DNS — означает использование провайдерских DNS, NTP — синхронизация времени, Add Default Route — добавлять ли стандартный маршрут в таблицу маршрутизации и Default Route Distance — приоритет маршрута по сравнению с другими, если у Вас несколько провайдеров то изменяя приоритет можно управлять предпочитаемым маршрутом для трафика, 0 — самый высокий приоритет. 

Или тоже самое в консоли:

/ip dhcp-client add interface=WAN1 disabled=no

Настройка подключения к провайдеру со статическим IP

В этом случае настройки из предыдущего пункта просто прописываются вручную. У некоторых провайдеров свой статический IP можно получить по DHCP — просто каждый раз, ваш роутер будет получать одни и те же настройки. При подключении со статическим IP нужно заранее узнать у провайдера свои настройки, IP, Маску сети, Gateway (шлюз), DNS.

Например провайдер выдал такие настройки:

IP адрес: 192.168.0.11;
Mask/маска сети: может быть в двух видах например 255.255.255.0 или /24 что одно и тоже, Микротик понимает оба вида, бытовые роутеры как правило только первый
Gateway/шлюз: 192.168.0.1;
DNS сервера: 192.168.0.33 и 192.168.0.34

Добавляем IP-адрес на порт WAN1: IP > Addresses > + >Address: 192.168.0.11/255.255.255.0 > Interface > WAN1

Добавляем default route:  IP > Routes > + > Dst.Address:0.0.0.0/0; Gateway:192.168.0.1; Check gateway: ping; Distance: 1

При «прямом» подключении к провайдеру с динамическим или статическим адресом, при добавлении маршрута нужно всегда указывать IP шлюза, в выпадающем списке там можно выбрать в качестве шлюза какой-либо интерфейс, работает это только с виртуальными интерфейсами PPPoE, PPTP, VPN и т. д.

Добавляем DNS: IP > DNS > Servers: 192.168.0.33; 192.168.0.34

Галку Allow Remote Requests можно поставить если Вы хотите чтоб микротик выступал в роли кеширующего DNS, но в этом случае необходимо запретить обработку запросов DNS поступающих на порты которые смотрят в сеть провайдера и разрешить обрабатывать запросы только из локальной сети. Серверов DNS можно вписать несколько, для добавления еще одной строчки надо жать маленькую кнопку «Вниз» около поля.

Все тоже самое из консоли:

/ip address add address=192.168.0.11/255.255.255.0 interface=WAN1
/ip route add dst-address=0.0.0.0/0 gateway=192.168.0.1 check-gateway=ping distance=1
/ip dns set servers=192.168.0.33,192.168.0.34

Подключение к провайдеру по PPPoE

Если у Вас подключение к провайдеру по PPPoE, то по идее можно пропустить два предыдущих пункта, но часто провайдеры предоставляют доступ к каким-то локальным ресурсам в своей сети, и если они вам нужны то сперва следует выполнить настройку подключения к провайдеру по DHCP и затем вернуться к этому пункту. В бытовых роутерах это зачастую называется DualAccess или Russian PPPoE, до версии прошивки 6.0 на Микротик настройка такого доступа требовала некоторых танцев, но теперь все работает из коробки, поэтому не будем останавливаться на этом моменте. Перед настройкой соединения PPPoE, Вы должны знать логин и пароль, которые у большинства провайдеров выдаются при подключении и часто написаны на специальном листке с настройками.

Добавляем интерфейс: PPP > + > PPPoE Client затем на вкладке General задаем желаемое имя интерфейса Name = ISP1 и выбираем порт куда подключен кабель от провайдера Interface = WAN1. На вкладке Dial Out укажите логин и пароль и проверьте что остальные галочки стоят как на скринах ниже:

Или команда для консоли:

/interface pppoe-client add interface=WAN1 name=ISP1 disabled=no user=Логин password=Пароль use-peer-dns=yes add-default-route=yes default-route-distance=0

Далее в качестве интерфейса смотрящего в интернет будет выступать ISP1 его и будем использовать в настройках.

Подключение к провайдеру по L2TP/PPTP

Честно говоря я не припоминаю чтоб хотя бы раз настраивал такое подключение, но в некоторых странах этот тип подключений по прежнему остается широко распространенным, поэтому рассмотрим и его. Оба типа подключения требуют предварительной настройки IP-адреса и возможно прописывания маршрутов, подробности обычно можно узнать на сайте провайдера или в его поддержке. Предполагается что с этим вы разобрались и настроили статический или динамический IP-адрес по инструкции выше, а так же узнали логин, пароль и адрес VPN сервера для подключения.
Настройка аналогична PPPoE:
Добавляем интерфейс PPTP/L2TP: PPP > + > PPTP Client или L2TP Client смотря что у Вас, на вкладке General укажите имя подключения (например ISP1), а на вкладке Dial out нужно указать адрес сервера, логин, пароль, в Profile выбрать Default, поставить галку Add default route и выставить Distance = 1

Изменять/заполнять нужно только выделенные поля

Команды для консоли:

Для pptp-client:
/interface pptp-client add name=ISP1 disabled=no connect-to=Адрес сервера user=Логин password=Пароль add-default-route=yes default-route-distance=1 profile=default

Для l2tp заменить pptp-client на :
/interface l2tp-client add name=ISP1 disabled=no connect-to=Адрес сервера user=Логин password=Пароль add-default-route=yes default-route-distance=1 profile=default

 Подключение к интернет через 3G/4G модемы

В нашей модели USB-порта нет,  если в Вашей есть то в общем случае модем нужно искать в разделе Interfaces > LTE:

И работать с ним как с обычным портом, получить настройки по DHCP, поднять соединение PPPoE и т. д. подводных камней там достаточно можно и их описание может потянуть еще на целую статью. Список поддерживаемых модемов есть тут.

Настройка локальной сети

Первый порт у нас подключен к провайдеру и в нашем случае остается еще 3 локальных порта плюс модуль WiFi (в других моделях локальных портов может быть больше, как и модулей WiFi), сейчас они все как бы висят в воздухе и никуда не подключены, никакой трафик никуда не ходит, а нам нужно чтоб ходил, для этого объединим локальные порты и создадим сетевой мост, который объединит локальные порты и WiFi. Все порты и модуль WiFi Вы можете переименовать как Вам удобно, я этого делать не буду. Объединять порты в Микротик можно двумя способами, аппаратным (но только те которые относятся к одному чипу) и программным можно объединить любые. Аппаратное объединение очевидно быстрее, им объединим локальные порты а затем создадим программный сетевой мост между ними и WiFi-интерфейсом. Один из локальных портов, удобнее всего последний выбираем главным (master), остальные подчиняем ему, делается это просто к примеру у нас последний 4-й порт, он будет главным, его настройки не меняются, заходим в третий и выбираем для него мастер-портом четвертый:

Повторяем операцию с оставшимися свободными портами и должно получиться вот так:

4-й порт мастер, хоть это нигде и не указано, 2-й и 3-й имеют пометку S — Slave, подчиненный в нашем случае.

Команды для консоли:

/interface ethernet set [find default-name=ether2] master-port=ether4
/interface ethernet set [find default-name=ether3] master-port=ether4

Для остальных портов команды аналогичные, нужно только сменить имена портов на свои. Теперь нужно добавить к нашей локальной сети WiFi интерфейс, для этого создадим Bridge (мост).

Сперва создадим сам мост, а затем добавим в него нужные порты:
Bridge > + > Name:bridge1
Bridge > Ports > + > Interface: ether4; Bridge: bridge1
Bridge > Ports > + > Interface: wlan1; Bridge: bridge1

Или можно выполнить в консоли:
/interface bridge add name=bridge1
/interface bridge port add interface=ether4 bridge=bridge1 
/interface bridge port add interface=wlan1 bridge=bridge1

Заметьте что в bridge1 мы добавляем только мастер-порт, теперь bridge1 это интерфейс который смотрит в локальную сеть, его и будем использовать в дальнейшем для настройки. Для того чтоб работала локальная сеть на  bridge1 — нужно добавить IP-адрес, а чтоб IP-адреса раздавались автоматически нужно на нем же поднять DHCP-сервер.

Добавляем ip на bridge1: IP > Addresses > + > Address: 192.168.88.1/24; Interface: bridge1

Или в консоли:
/ip address add address=192.168.88.1/24 interface=bridge1

Далее нужно настроить раздачу IP-адресов для всех устройств подключенных к нашей локальной сети, как проводом так и по WiFi, сделать это можно двумя способами, с помощью мастера и вручную. Ниже показаны оба варианта, первый с помощью мастера, заходим в меню IP > DHCP Server > DHCP Setup и далее заполняем нужные поля и жмем Next. 

Все скрины я приводить не буду, статья и так длинная, мастер спросить на каком интерфейсе поднимать сервер в нашем случае это bridge1, затем адрес сети — 192.168.88.0/24, затем адрес шлюза — 192.168.88.1, затем размер пула в виде начального и конечного адреса — 192.168.88.100-192.168.88.254, затем нужно указать DNS сервера, я обычно использую гугловские 8.8.8.8 и 8.8.4.4, затем указываем время аренды, значение по умолчанию 00:10:00 — 10 минут, можно изменить на свое, можно оставить так, и на этом настройка закончена.
Все тоже самое можно настроить и вручную:
Создаем пул из которого будем выдавать адреса, в примере на 100 адресов, вы можете сделать его больше или меньше: IP > Pool > + > Name: pool1; Addresses:192.168.88.100-192.168.88.200

Или в консоли:
/ip pool add name=pool1 address=192.168.88.100-192.168.88.200

Теперь можно добавлять DHCP сервер на интерфейс bridge1 IP > DHCP Server > + , Name = dhcp1, Interface = bridge1, Address Pool = pool, остальные настройки не трогаем, Lease Time  у меня стоит полчаса, в домашней сети можно ставить 8 часов и больше:
Теперь переходим на вкладку Network, там нужно указать какие параметры будет отдавать наш сервер своим клиентам, необходимый минимум для работы сети Address, Gateway, Netmask — ее можно указать отдельно в поле или дописать к IP-адресу через / и DNS:

Или в консоли:
/ip dhcp-server add name=dhcp1 interface=bridge1 lease-time=00:30:00 address-pool=pool1
/ip dhcp-server network add address=192.168.88.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.88.1 netmask=24

Настройка WiFi

Я много раз настраивал Wi-Fi на Mikrotik, настройки по умолчанию — работают всегда, поэтому рекомендую их не трогать, если только Вы не уверены в том что делаете. Но иногда их можно оптимизировать под конкретную ситуацию, можно увеличить радиус покрытия, стабильность связи и в целом по сравнению с любым бытовым роутером, Микротик дает гораздо больше возможностей по настройке, что в условиях зашумленного городского эфира значительно повышает шансы добиться стабильной работы. Если все нормально работает с настройками по умолчанию — рекомендую их не трогать.

Активируем беспроводной интерфейс и приступаем к его настройке:

Настроим профиль безопасности, имя любое, некоторые старые устройства не умеют работать с шифрованием AES для них возможно придется включить устаревший вариант TKIP, который не рекомендуется из-за слабой безопасности, в поля Pre-Shared Key вводим пароль на нашу точку:

Настраиваем сам беспроводной интерфейс:

Вкладка Wireless:
Mode: ap bridge;
Band: 2gHz-B/G/N, если в сети нет старых устройств рекомендую выбирать Only-N, медленно но стабильно Only-G или 2gHz-B/G, в общем если не работает как надо экспериментируйте;
Channel Width: 20 MHz, если эфир свободен и Ваши устройства поддерживают можно поставить 40, скорость увеличится;фи
Frequency: auto, это тоже самое что и каналы в бытовых роутерах, рекомендую поставить авто, конкретный канал ставьте если знаете что делаете;
SSID: Название точки доступа;
Wireless Protocol: 802.11;
Securiity Profile: my_wifi, выбираем профиль созданный ранее;
Bridge Mode: enabled;
Default Authenticate: yes;
Default Forward: yes;
Hide SSID: no, позволяет скрывать Вашу точку из списка найденных устройств и в этом случае подключаться к ней придется вручную вводя имя, в общем жизнь эта настройка усложняет только владельцу, взломщики легко находят скрытые точки;

Далее вкладка Nstreme.
Отключаем все.

Консольный вариант:

/interface wireless set wlan1 disabled=no ssid=Mikrotik mode=ap-bridge band=2ghz-b/g/n frequency=auto bridge-mode=enabled wireless-protocol=any security-profile=my_wifi default-authentication=yes default-forwarding=yes hide-ssid=no
/interface wireless nstreme set wlan1 enable-nstreme=no enable-polling=no disable-csma=no

Теперь у нас есть рабочее подключение к Интернет и настроенная локальная сеть c WiFi, осталось «соединить» их между собой с помощью правил пакетного фильтра.

 Настройка пакетного фильтра (файервол)

Для настройки пакетного фильтра который по синтаксису схож с iptables, можно использовать Winbox или консоль, так как правил может быть много я опишу общий принцип, а вы выберете то что вам удобнее. Для настройки надо зайти в IP->Firewall, нас будут интересовать первые три вкладки Filter Rules, NAT и Mangle, каждая вкладка содержит список правил которые обрабатываются сверху вниз, кнопками плюс/минус правила можно добавлять и удалять, так же правила можно включать и отключать кнопками галочка/крестик. При нажатии на плюс, откроется новое окно для добавления правила, на вкладках General, Advanced и Extra задаются условия, на вкладке Action — выбирается действие для пакетов попавших под выбранные Вами условия, в большинстве случаев достаточно условий с вкладки General:
В большинстве случаев каждый пакет обрабатывается первым правилом под условия которого попал и дальше не проходит, но это поведение можно изменять.

Что делают правила из примера?
Доступ к Mikrotik будет полностью закрыт извне, но разрешен изнутри сети, на пинги Микротик будет отвечать и снаружи и изнутри, у пользователей внутри сети появится интернет. Это минимально необходимый набор правил. У вас должно получиться вот так:

Если будете добавлять правила через Winbox, жмете плюсик, и заполняете соответствующие поля значениями из скриншота выше, нужно добавить все 9 правил и именно в таком порядке. После переходите на вкладку NAT и по такому же принципу добавляете еще одно правило:

Но гораздо проще и быстрее отредактировать если нужно правила в текстовом редакторе и скопировать их в терминал, не забудьте нажать Enter, иначе последнее правило может не примениться:

Список команд с правилами пакетного фильтра для консоли:
/ip firewall filter
add chain=input protocol=icmp
add chain=input connection-state=new dst-port=80,8291,22 in-interface=bridge1 protocol=tcp src-address=192.168.88.0/24
add chain=input connection-state=new dst-port=53,123 protocol=udp src-address=192.168.88.0/24
add chain=input connection-state=established,related
add chain=output connection-state=!invalid
add chain=forward connection-state=established,new in-interface=bridge1 out-interface=WAN1 src-address=192.168.88.0/24
add chain=forward connection-state=established,related in-interface=WAN1 out-interface=bridge1
add action=drop chain=input
add action=drop chain=output
add action=drop chain=forward

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1 src-address=192.168.88.0/24

Если все сделано верно — то на устройствах подключенных к Mikrotik по WiFi или локальной сети должен появиться интернет. Это первая часть статьи, в ней мы настроили Mikrotik под себя и получили функционал обычного бытового роутера, но плюс RouterOS в том что она позволяет делать гораздо больше чем любой бытовой роутер, в ближайшем времени планирую написать вторую часть с рассказом о дополнительных возможностях и примерами по их настройке. Статью и команды в ней я проверял, но все же где-то могли закрасться ошибки, если у Вас что-то не получается сразу же пишите в комментариях, я перепроверю и помогу.

Спонсор статьи:

Самоучитель по MikroTik – теория и практика в видеоформате.

По видеокурсу «Настройка оборудования MikroTik» вы научитесь настраивать маршрутизатор с нуля для целей небольшого офиса. В основе курса лежит официальная программа MikroTik Certified Network Associate, но она значительно расширена, особенно в части закрепления знаний на практике. В курс входит 162 видеоурока и 45 лабораторных работ, объединенных в техническое задание. Если что-то непонятно, то можно задавать вопросы автору курса. Первые 25 уроков можно посмотреть бесплатно, форма заказа есть на странице курса по MikroTik.